Installed Checkpoint R77.20 in virtual machine to do testing. The installation of gateway and mgmt server is not having problem, but had an issue while installing SmartConsole R77.20 on windows 7 machine.

Symptons:

1. First error I met is at during installation. 

Unable to register dlls in:
C:Program FilesCheckPointSmartConsoleR77.20PROGRAMpe_components_reg.conf

 After clicked OK button, installation was able to complete.

2. Second error message is popped up when tried to run SmarConsole applications, such as SmartDashboard, SmartTrack, SmartMonitor etc. 

This error is common happened. Google Internet for “The program can’t start because MSVCR100.dll is missing from your computer.”. You will get tons of solutions. Basically just need to install one of following Microsoft Visual C++ Redistributable package :
32 bit: http://www.microsoft.com/download/en/details.aspx?id=5555
64 bit: http://www.microsoft.com/download/en/details.aspx?id=14632

3. Finally I got the SmarDashboard Log in Window:

 Typed username , password and mgmt server ip address, clicked login. SmartDashboard window disappeared at loading application data at 15%.

Solutions:

I was keeping trying to system update, install patch, re-install R77.20 with different ways. Finally I got the following solutions on my windows 7 machine:

1. Install R77.10 SmartConsole first

2. Install R77.20 SmartConsole

—————————————————————————————————————————————
Notes: 

Another troubleshooting tool from Checkpoint is traceutil.exe:

To enable logs in UI do the following:
1) Open the TraceUtil.exe found under the Smart Console install directory (C:Program Files (x86)CheckPointSmartConsoleR77.10PROGRAM)

2) Check enabled in Endpoint Security Console, and output to file, you should select a location of the file with ‘…’ button

3) Under the topics click add , type ALL in topic and 5 in level, click OK

4) Click Apply on the dialog, next time you will run the Endpoint Management, logs would be created.

The logs may be ok to send to Checkpoint support, but not useful for me to figure out the problem I were facing.

By Jon

23 thoughts on “Checkpoint SmartConsole R77.20 Installation Issue – SmartDashboard ‘Loading local configuration’ up to 15% and then disappears”
  1. THANKS! I confirm it is a workaround also for Windows 2003. I wish Check Point consider improving its TESTING phase before releasing.

  2. YOU CHAMPION! This has been bugging me for AGES. I only had this problem when installing SmartConsole in a Windows VM (ESXi). But this works… thanks again for bothering to post this. Saved me massive headaches!

  3. thanks. confirmed that same issue apply in R77.30.. R77.10 first (I think .Net4 is the breaker)

  4. FYI – this seems to only work for me with Server 2012 R2 and the 32-bit Visual C++ Redistributable on R77.20. 64-bit bombs with the same errors during install.

    I had to uninstall and reinstall after the 32-bit version was installed. I also didn't receive the .dll error message during the install with the 32-bit version installed.

    I hope this saves other folks from head scratching and time wasting.

  5. I tried to install a R77.20 iso image I found chucked away in the internet maze, installed it in VMware fusion with default settings using the SATA instead of the SCSI… I was able to install the Manager & Gateway. I am having trouble installing the Console and I did try everything that you said above but it seems it's not working… Tried it on XP and 7 with the same error message… Any others have a workaround I can use?

  6. 32 bit vc++ redistributable solved the issue for me (win7 64bit OS)
    after installation of 32 bit redistributable, I have to uninstall and install again the dashboard and the problem got fixed

  7. I ran into same issue, I am trying to download "R77.10 SmartConsole" checkpoint says I am not entitled to download this file. Man, what a load of craps, come on a "stupidConsole," why would check point restrict downloading. what people are going to use with the stupid console with no firewall app.

  8. Guys I have installed r77.30 but i am unable to login because the application is disappearing after typing the password.I have already done some changes as per above instructions but no success. please advise.

  9. I believe you need to install/enable Mircrosft .NET Framework 2.0 SP2. or .net ver required according to your particular windows OS
    It is a pre-requiste for installation of smart console

  10. I have written the whole list of pre-requisites I hope it helps
    Windows Installer version 3.1 or higher is required to perform this installation.
    Microsoft .NET Framework 2 SP2
    Microsoft .NET Framework 4
    Microsoft Visual C++ 2010 Redistributable Package
    Windows Imaging Component

  11. Windows Installer version 3.1 or higher is required to perform this installation.
    Microsoft .NET Framework 2 SP2
    Microsoft .NET Framework 4
    Microsoft Visual C++ 2010 Redistributable Package
    Windows Imaging Component

Leave a Reply